Heartbleed Vulnerability Update

By Stephanie Newman
Friday, April 11, 2014 / Less than a minute read

heartbleed

This week, a major security flaw was detected in OpenSSL, the open-source encryption standard used by the majority of popular websites and services like Google, Facebook, Yahoo! and more. Here at Fyber (formerly SponsorPay), as soon as we were aware of this issue we took immediate steps to patch our systems against the vulnerability.

We have no evidence of any malicious behavior, but we wanted to strongly encourage you to change your Fyber (formerly SponsorPay) password. If you’re a developer, please log in to the Developer Dashboard, then go to “Account” and then “Change Password”. If you’re an advertiser, please log in to the Advertiser Control Panel, then go to “Account” and then to “Login Data”.

We also recommend that you follow best practices and periodically change your passwords everywhere, including Fyber (formerly SponsorPay). When changing your password, you can follow these simple best practices:

  • Do not use any part of your username or service name in the password.
  • Try to make it at least 8 characters long.
  • Try to mix letters and special characters in a combination you can remember.
Please feel free to contact us if you have any questions.